您的位置:首页 > 其它

1050. String Subtraction (20)【字符串处理】——PAT (Advanced Level) Practise

2015-12-06 21:27 676 查看

题目信息

1050. String Subtraction (20)

时间限制10 ms

内存限制65536 kB

代码长度限制16000 B

Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1. Your task is simply to calculate S1 - S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S1 and S2, respectively. The string lengths of both strings are no more than 10^4. It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 - S2 in one line.

Sample Input:

They are students.

aeiou

Sample Output:

Thy r stdnts.

解题思路

排除s2中字符输出即可

AC代码

#include <cstdio>
#include <cstring>
char s[10005], aim[10005];

int main()
{
gets(s);
gets(aim);
int len = strlen(s);
for (int i = 0; i < len; ++i){
if (NULL == strchr(aim, s[i])){
putchar(s[i]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 1050 字符串