您的位置:首页 > 其它

1049. Counting Ones (30)【计算1 的个数】——PAT (Advanced Level) Practise

2015-12-06 21:25 489 查看

题目信息

1049. Counting Ones (30)

时间限制10 ms

内存限制65536 kB

代码长度限制16000 B

The task is simple: given any positive integer N, you are supposed to count the total number of 1’s in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1’s in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (<=2^30).

Output Specification:

For each test case, print the number of 1’s in one line.

Sample Input:

12

Sample Output:

5

解题思路

《编程之美》中计算0到N包含数字1的个数问题

AC代码

#include <cstdio>

int get(long long n){
long long cur = 0, before = 0, after = 0, i = 1, cnt = 0;
while ((n / i) != 0){
cur = n / i % 10;
before = n / i / 10;
after = n - (n / i) * i;
if (cur == 0){
cnt += before * i;
}else if (cur == 1){
cnt += before * i + after + 1;
}else {
cnt += (before + 1) * i;
}
i *= 10;
}
return cnt;
}

int main()
{
long long a;
scanf("%lld", &a);
printf("%d\n", get(a));
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 1049