您的位置:首页 > 其它

1047. Student List for Course (25)【排序】——PAT (Advanced Level) Practise

2015-12-06 21:17 666 查看

题目信息

1047. Student List for Course (25)

时间限制400 ms

内存限制64000 kB

代码长度限制16000 B

Zhejiang University has 40000 students and provides 2500 courses. Now given the registered course list of each student, you are supposed to output the student name lists of all the courses.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=40000), the total number of students, and K (<=2500), the total number of courses. Then N lines follow, each contains a student’s name (3 capital English letters plus a one-digit number), a positive number C (<=20) which is the number of courses that this student has registered, and then followed by C course numbers. For the sake of simplicity, the courses are numbered from 1 to K.

Output Specification:

For each test case, print the student name lists of all the courses in increasing order of the course numbers. For each course, first print in one line the course number and the number of registered students, separated by a space. Then output the students’ names in alphabetical order. Each name occupies a line.

Sample Input:

10 5

ZOE1 2 4 5

ANN0 3 5 2 1

BOB5 5 3 4 2 1 5

JOE4 1 2

JAY9 4 1 2 5 4

FRA8 3 4 2 5

DON2 2 4 5

AMY7 1 5

KAT3 3 5 4 2

LOR6 4 2 4 1 5

Sample Output:

1 4

ANN0

BOB5

JAY9

LOR6

2 7

ANN0

BOB5

FRA8

JAY9

JOE4

KAT3

LOR6

3 1

BOB5

4 7

BOB5

DON2

FRA8

JAY9

KAT3

LOR6

ZOE1

5 9

AMY7

ANN0

BOB5

DON2

FRA8

JAY9

KAT3

LOR6

ZOE1

解题思路

分组后排序

AC代码

#include <cstdio>
#include <vector>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
char name[40005][5];
bool cmp(const int a, const int b){
return strcmp(name[a], name[b]) < 0;
}
vector<int> st[2505];
int main()
{
int n, k, tn, t;
scanf("%d%d", &n, &k);
for (int i = 0; i < n; ++i){
scanf("%s%d", name[i], &tn);
for (int j = 0; j < tn; ++j){
scanf("%d", &t);
st[t].push_back(i);
}
}
for (int i = 1; i <= k; ++i){
printf("%d %d\n", i, st[i].size());
sort(st[i].begin(), st[i].end(), cmp);
for (vector<int>::iterator it = st[i].begin(); it != st[i].end(); ++it){
printf("%s\n", name[*it]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 1047 排序