您的位置:首页 > 其它

A - 这是在网吧出的题!!

2015-12-06 12:31 323 查看
Description

Mob was hijacked by the mayor of the Town "TruthTown". Mayor wants Mob to count the total population of the town. Now the naive approach to this problem will be counting people one by one. But as we all know Mob is a bit lazy, so he is finding some other
approach so that the time will be minimized. Suddenly he found a poll result of that town where N people were asked "How many people in this town other than yourself support the same team as you in the FIFA world CUP 2010?" Now Mob wants to
know if he can find the minimum possible population of the town from this statistics. Note that no people were asked the question more than once.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with an integer N (1 ≤ N ≤ 50). The next line will contain N integers denoting the replies (0 to 106) of the people.

Output

For each case, print the case number and the minimum possible population of the town.

Sample Input

2

4

1 1 2 2

1

0

Sample Output

Case 1: 5

Case 2: 1

向上取整,容器大小。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[100];
int main()
{
int t;
scanf("%d",&t);
int d=1;
while(t--)
{
memset(a,0,sizeof(a));
int n;
scanf("%d",&n);
int i;
int sum=0;
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n);
int cnt=0;
for(i=0;i<n;i++)
{
if(i==0||a[i]==a[i-1])
cnt++;
else
{
sum+=(cnt+a[i-1])/(a[i-1]+1)*(a[i-1]+1);
cnt=0;
}
}
sum+=(cnt+a[n-1])/(a[n-1]+1)*(a[n-1]+1);
printf("Case %d: ",d++);//冒号之后有空格!!!!
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: