您的位置:首页 > 其它

1063. Set Similarity (25)遍历map

2015-12-06 11:18 393 查看
Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:[/b]
3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3
Sample Output:[/b]
50.0%
33.3%

来源: <http://www.patest.cn/contests/pat-a-practise/1063>

#include<iostream>

#include <map>

#include <vector>

#include <algorithm>

#include <string>

#include <stdio.h>

#pragma warning(disable:4996)

#include <set>

using namespace std;


vector<map<int, int>> v;


int main(void) {

int n;

cin >> n;

for (int i = 0; i < n; i++) {

map<int, int> mp;

v.push_back(mp);

}


for (int i = 0; i < n; i++) {

int m;

cin >> m;

for (int j = 0; j < m; j++) {

int num;

cin >> num;

v[i][num]++;

}

}

int k;

cin >> k;

for (int i = 0; i < k; i++) {

int a, b;

cin >> a >> b;

if (v[a - 1].size() > v[b - 1].size()) {

int temp;

temp = a;

a = b;

b = temp;

}

int cnt = 0;

//遍历 map 获取(key,value)

for (auto &kv : v[a - 1]) {

//cout << kv.first << " has value " << kv.second << endl;

if (v[b - 1].count(kv.first))

cnt++;

}


double similarity;

similarity = 1.0*cnt / (v[a - 1].size() + v[b - 1].size() - cnt);

similarity *= 100;

printf("%.1f", similarity);

cout << "%" << endl;

}

return 0;

}

[/code]

来自为知笔记(Wiz)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: