您的位置:首页 > 其它

1056. Mice and Rice (25)

2015-12-06 11:11 309 查看
使用队列来模拟还在的人

时间限制30 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for NP programmers. Then every NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every NGwinners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: NP and NG (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains NP distinct non-negative numbers Wi (i=0,...NP-1) where each Wiis the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...NP-1 (assume that the programmers are numbered from 0 to NP-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

来源: <http://www.patest.cn/contests/pat-a-practise/1056>
#include<iostream>

#include<stdio.h>

#include<vector>

#pragma warning(disable:4996)

#include<queue>

using namespace std;


int np, ng;

int weight[1010] = { 0 };

int rank1[1010] = { 0 };

int mark[1010] = { 0 };

queue<int> order, nextRound;


int main(void) {

freopen("Text.txt", "r", stdin);


cin >> np >> ng;

for (int i = 0; i < np; i++) {

cin >> weight[i];

}

for (int i = 0; i < np; i++) {

int temp;

cin >> temp;

order.push(temp);

}


while (true)

{

int nextRoundCnt = order.size() / ng;

if (order.size() %ng != 0)

nextRoundCnt++;

int outRank = nextRoundCnt + 1;

for (int i = 0; i < nextRoundCnt; i++) {

int max = -1, maxIndex = -1;

for (int j = 0; j < ng &&order.empty()==false; j++) {

if (weight[order.front()] > max) {

if (maxIndex != -1) {

rank1[maxIndex] = outRank;

}

max = weight[order.front()];

maxIndex = order.front();

}

else {

rank1[order.front()] = outRank;

}

order.pop();

}

nextRound.push(maxIndex);

}

int size = nextRound.size();

for (int i = 0; i < size; i++) {

order.push(nextRound.front());

nextRound.pop();

}

if (order.size() == 1) {

rank1[order.front()] = 1;

break;

}

}


for (int i = 0; i < np; i++) {

cout << rank1[i];

if (i != np - 1)

cout << " ";

}

return 0;



}

[/code]

来自为知笔记(Wiz)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: