您的位置:首页 > 其它

1053. Path of Equal Weight (30)

2015-12-06 11:06 357 查看
dfs函数携带vector形参记录搜索路径

时间限制10 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.



Figure 1Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bifor i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
来源: <http://www.patest.cn/contests/pat-a-practise/1053>
#include <iostream>

#include <map>

#include <vector>

#include <algorithm>


using namespace std;


map<int, vector<int>> mp;


vector<int> weight;

int n, m, aimWeight;

int pathWeight=0;


bool cmp(int a, int b) {

return weight[a] > weight[b];

}


void dfs(int i,int w, vector<int> p) {

p.push_back(i);


if (mp[i].size() == 0) {

if (w == aimWeight) {

for (int j = 0; j < p.size(); j++) {

cout << weight[p[j]];

if (j != p.size() - 1)

cout << " ";

else

cout << endl;

}

}

p.clear();

return;

}


else {

for (int j = 0; j < mp[i].size(); j++)

dfs(mp[i][j],weight[mp[i][j]]+w,p);

}

}


int main(void) {

cin >> n >> m >> aimWeight;

for (int i = 0; i < n; i++) {

int wtemp;

cin >> wtemp;

weight.push_back(wtemp);

}

for (int i = 0; i < m; i++) {

int id, k;

cin >> id >> k;

for (int j = 0; j < k; j++) {

int idtemp;

cin >> idtemp;

mp[id].push_back(idtemp);

}

sort(mp[id].begin(), mp[id].end(), cmp);

}

vector<int> path;

dfs(0,weight[0],path);


return 0;

}

[/code]

来自为知笔记(Wiz)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: