您的位置:首页 > 其它

1031. Hello World for U (20)

2015-12-06 10:36 183 查看
时间限制400 ms
内存限制65536 kB
代码长度限制16000 B
判题程序Standard作者CHEN, Yue
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:

h  d
e  l
l  r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!
Sample Output:
h   !
e   d
l   l
lowor
来源: <http://www.patest.cn/contests/pat-a-practise/1031>
#pragma warning(disable:4996)

#include <stdio.h>

#include <string>

#include <iostream>


using namespace std;


int main(void) {

int n1, n2, n3;

string s;

cin >> s;

n1 = n3 = (s.length() - 1) / 3;

n1++; n3++;

n2 = s.length() + 2 - 2 * n1;


for (int i = 0; i < n1 - 1; i++) {

cout << s[i];

for (int i = 0; i < n2 - 2; i++)

cout << ' ';

cout << s[s.length() - i - 1] << endl;

}

for (int i = n1 - 1; i < n1 + n2-1; i++) {

cout << s[i];

}


return 0;


}

[/code]

来自为知笔记(Wiz)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: