您的位置:首页 > 其它

Max Sum

2015-12-06 10:34 399 查看

Max Sum


Time Limit: 2000ms Memory limit: 32768K 有疑问?点这里^_^

题目描述

Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

输入

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

输出

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position
of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

示例输入

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


示例输出

Case 1:
14 1 4

Case 2:
7 1 6


提示

hdoj1003 注意:本题后台测试数据量比较大,请使用C语言scanf输入。避免超时!!!!

来源

Ignatius.L
#include<stdio.h>
int main()
{
int t;
scanf("%d",&t);
int cases=1;
while(t--)
{
int n,i;
scanf("%d",&n);
int sum=0,max=-9999;
int start=1,end=1,tmp=1;
int num;
for(i=1;i<=n;i++)
{
scanf("%d",&num);
sum+=num;
if(max<sum)
{
max=sum;
start=tmp;
end=i;
}
if(sum<0)
{
sum=0;
tmp=i+1;
}
}
printf("Case %d:\n",cases);
printf("%d %d %d\n",max,start,end);
if(t!=0)
printf("\n");
cases++;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: