您的位置:首页 > 其它

1027. Colors in Mars (20)

2015-12-06 10:33 232 查看
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456
提交代码

来源: <http://www.patest.cn/contests/pat-a-practise/1027>

#pragma warning(disable:4996)

#include <stdio.h>

#include <iostream>


using namespace std;


string Change(int i) {

string s,s1,s2;

int a, b;

a = i / 13;

b = i % 13;


char c, d;

if (a < 10)

c = (a + '0');

else

c = (a - 10 + 'A');


if (b < 10)

d = (b + '0');

else

d = (b - 10 + 'A');


s1 = c;

s2 = d;

s = s1 + s2;

return s;


}


int main(void) {

int r, g, b;

cin >> r >> g >> b;

string s1, s2, s3;

s1 = Change(r);

s2 = Change(g);

s3 = Change(b);


printf("#");

//printf("%s%s%s", s1,s2 ,s3 );

cout << s1[0]<<s1[1];

cout << s2[0] << s2[1];

cout << s3[0] << s3[1];

return 0;




}

[/code]

来自为知笔记(Wiz)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: