您的位置:首页 > 其它

Message Decowding

2015-12-06 10:32 288 查看

Message Decowding


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

The cows are thrilled because they've just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms.

Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher.

The cows have a decryption key and a secret message. Help them decode it. The key looks like this:

yrwhsoujgcxqbativndfezmlpk

Which means that an 'a' in the secret message really means 'y'; a 'b' in the secret message really means 'r'; a 'c' decrypts to 'w'; and so on. Blanks are not encrypted; they are simply kept in place.

Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course

输入

* Line 1: 26 lower case characters representing the decryption key

* Line 2: As many as 80 characters that are the message to be decoded

输出

* Line 1: A single line that is the decoded message. It should have the same length as the second line of input.

示例输入

eydbkmiqugjxlvtzpnwohracsf
Kifq oua zarxa suar bti yaagrj fa xtfgrj


示例输出

Jump the fence when you seeing me coming


来源

USACO 2003 March Orange
#include<stdio.h>
#include<string.h>
int main()
{
char tmp,keys[26];
while(scanf("%s",keys)!=EOF)
{
getchar();
while((tmp=getchar())!='\n')
{
if(tmp>='a' && tmp<='z')
putchar(keys[tmp-'a']);
else if(tmp>='A' && tmp<='Z')
putchar(keys[tmp-'A']-32);
else
putchar(tmp);
}
putchar(tmp);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: