您的位置:首页 > 其它

Ants

2015-12-05 23:38 639 查看

Ants


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite
directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

输入

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers
are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

输出

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is
the latest possible such time.

示例输入

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191


示例输出

4 8
38 207


提示

来源

面向对数据结构和算法不太了解的同学

示例程序

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

inline int max(int a,int b){ return a>b?a:b; }
inline int min(int a,int b){ return a<b?a:b; }

int main(){
int nCase, len, n, dist;
scanf("%d",&nCase);
while(nCase--){
scanf("%d%d",&len, &n);
int minLen = -100, maxLen = -100;
for(int i=0; i<n; ++i){
scanf("%d",&dist);
maxLen = max(maxLen, max(dist, len-dist));
minLen = max(minLen, min(dist, len-dist));
}
printf("%d %d\n", minLen, maxLen);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: