您的位置:首页 > 其它

Symmetric Order

2015-12-05 23:37 363 查看

Symmetric Order


Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

In your job at Albatross Circus Management (yes, it's run by a bunch of clowns), you have just finished writing a program whose output is a list of names in nondescending order by length (so that each name is at least as long as the one
preceding it). However, your boss does not like the way the output looks, and instead wants the output to appear more symmetric, with the shorter strings at the top and bottom and the longer strings in the middle. His rule is that each pair of names belongs
on opposite ends of the list, and the first name in the pair is always in the top part of the list. In the first example set below, Bo and Pat are the first pair, Jean and Kevin the second pair, etc.

输入

The input consists of one or more sets of strings, followed by a final line containing only the value 0. Each set starts with a line containing an integer, n, which is the number of strings in the set, followed by n strings, one per line,
sorted in nondescending order by length. None of the strings contain spaces. There is at least one and no more than 15 strings per set. Each string is at most 25 characters long.

输出

For each input set print "SET n" on a line, where n starts at 1, followed by the output set as shown in the sample output.

示例输入

7
Bo
Pat
Jean
Kevin
Claude
William
Marybeth
6
Jim
Ben
Zoe
Joey
Frederick
Annabelle
5
John
Bill
Fran
Stan
Cece
0


示例输出

SET 1
Bo
Jean
Claude
Marybeth
William
Kevin
Pat
SET 2
Jim
Zoe
Frederick
Annabelle
Joey
Ben
SET 3
John
Fran
Cece
Stan
Bill


提示

来源

面向对数据结构和算法不太了解的同学

示例程序

#include<stdio.h>
#include<string.h>
int main (void)
{
int n,i,j,leng[40];
char a[30][30];
int dd=1;
while(~scanf("%d",&n)&&n)
{
for(i=1; i<=n; i++)
{
scanf("%s",a[i]);
}
printf("SET %d\n",dd);
dd++;
for(i=1; i<=n; i++)
{
if(2*i-1<=n)
{
printf("%s\n",a[i*2-1]);
}
}
if(n%2==1)
{
for(i=1; i<=n/2; i++)
{
printf("%s\n",a[n-(i*2-1)]);
}
}
if(n%2==0)
{
for(i=1;i<n;i+=2)
{
printf("%s\n",a[n-i+1]);
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: