您的位置:首页 > 其它

lightoj Just another Robbery 1079 (01背包转换&概率)

2015-12-05 22:22 218 查看
LightOJ - 1079
Just another Robbery

Time Limit: 4000MSMemory Limit: 32768KB64bit IO Format: %lld & %llu
Submit Status

Description

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have
decided upon a tolerable probability Pof getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives
an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj.
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6

 

#include<stdio.h>
#include<string.h>
double max(double a,double b)
{
return a>b?a:b;
}
double dp[10100];
struct zz
{
int v;
double p;
}q[1010];
int main()
{
int t,T=1;
int n,i,j;
double p,x;
scanf("%d",&t);
while(t--)
{
scanf("%lf%d",&p,&n);
double pp=1-p;
int sum=0;
for(i=1;i<=n;i++)
{
scanf("%d%lf",&q[i].v,&x);
sum+=q[i].v;
q[i].p=1-x;
}
memset(dp,0,sizeof(dp));
dp[0]=1;
for(i=1;i<=n;i++)
{
for(j=sum;j>=q[i].v;j--)
{
dp[j]=max(dp[j],dp[j-q[i].v]*q[i].p);
}
}
printf("Case %d: ",T++);
for(i=sum;i>=0;i--)
{
if(dp[i]>=pp)
{
printf("%d\n",i);
break;
}
}
}
return 0;
}


 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: