您的位置:首页 > 其它

hdoj5591ZYB's Game

2015-12-05 22:20 543 查看


ZYB's Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 88    Accepted Submission(s): 77


Problem Description

ZYB played
a game named NumberBomb with
his classmates in hiking:a host keeps a number in [1,N] in
mind,then 

players guess a number in turns,the player who exactly guesses X loses,or
the host will tell all the players that

the number now is bigger or smaller than X.After
that,the range players can guess will decrease.The range is [1,N] at
first,each player should guess in the legal range.

Now if only two players are play the game,and both of two players know the X,if
two persons all use the best strategy,and the first player guesses first.You are asked to find the number of X that
the second player

will win when X is
in [1,N].

 

Input

In the first line there is the number of testcases T.

For each teatcase:

the first line there is one number N.

1≤T≤100000,1≤N≤10000000

 

Output

For each testcase,print the ans.

 

Sample Input

1
3

 

Sample Output

1

 
#include<stdio.h>
int main()
{
int t,n;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
if(n&1)printf("1\n");
else printf("0\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdoj5591ZYBs Game