您的位置:首页 > 其它

hdoj 5023 A Corrupt Mayor's Performance Art 【线段树区间修改 + 状压】

2015-12-05 21:40 302 查看


A Corrupt Mayor's Performance Art

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 100000/100000 K (Java/Others)

Total Submission(s): 1800    Accepted Submission(s): 626

Problem Description

Corrupt governors always find ways to get dirty money. Paint something, then sell the worthless painting at a high price to someone who wants to bribe him/her on an auction, this seemed a safe way for mayor X to make money.

Because a lot of people praised mayor X's painting(of course, X was a mayor), mayor X believed more and more that he was a very talented painter. Soon mayor X was not satisfied with only making money. He wanted to be a famous painter. So he joined the local
painting associates. Other painters had to elect him as the chairman of the associates. Then his painting sold at better price.

The local middle school from which mayor X graduated, wanted to beat mayor X's horse fart(In Chinese English, beating one's horse fart means flattering one hard). They built a wall, and invited mayor X to paint on it. Mayor X was very happy. But he really had
no idea about what to paint because he could only paint very abstract paintings which nobody really understand. Mayor X's secretary suggested that he could make this thing not only a painting, but also a performance art work.

This was the secretary's idea:

The wall was divided into N segments and the width of each segment was one cun(cun is a Chinese length unit). All segments were numbered from 1 to N, from left to right. There were 30 kinds of colors mayor X could use to paint the wall. They named those colors
as color 1, color 2 .... color 30. The wall's original color was color 2. Every time mayor X would paint some consecutive segments with a certain kind of color, and he did this for many times. Trying to make his performance art fancy, mayor X declared that
at any moment, if someone asked how many kind of colors were there on any consecutive segments, he could give the number immediately without counting.

But mayor X didn't know how to give the right answer. Your friend, Mr. W was an secret officer of anti-corruption bureau, he helped mayor X on this problem and gained his trust. Do you know how Mr. Q did this?

 

Input

There are several test cases.

For each test case:

The first line contains two integers, N and M ,meaning that the wall is divided into N segments and there are M operations(0 < N <= 1,000,000; 0<M<=100,000) 

Then M lines follow, each representing an operation. There are two kinds of operations, as described below: 

1) P a b c 

a, b and c are integers. This operation means that mayor X painted all segments from segment a to segment b with color c ( 0 < a<=b <= N, 0 < c <= 30).

2) Q a b

a and b are integers. This is a query operation. It means that someone asked that how many kinds of colors were there from segment a to segment b ( 0 < a<=b <= N).

Please note that the operations are given in time sequence.

The input ends with M = 0 and N = 0.

 

Output

For each query operation, print all kinds of color on the queried segments. For color 1, print 1, for color 2, print 2 ... etc. And this color sequence must be in ascending order.

 

Sample Input

5 10
P 1 2 3
P 2 3 4
Q 2 3
Q 1 3
P 3 5 4
P 1 2 7
Q 1 3
Q 3 4
P 5 5 8
Q 1 5
0 0

 

Sample Output

4
3 4
4 7
4
4 7 8

 

题意:给个墙的区间,初始涂的为颜色二,有M次操作。P x y z 表示把[x, y]涂成颜色z,Q x y 输出区间[x, y]里面的颜色。

思路:直接用个变量状态压缩记录颜色种类就好了。

AC代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <vector>
#define INF 0x3f3f3f
#define eps 1e-8
#define MAXN (1000000+10)
#define MAXM (100000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
struct Tree
{
int l, r, len;
int color;
int lazy;
};
Tree tree[MAXN<<2];
void PushUp(int o){
tree[o].color = tree[ll].color | tree[rr].color;
}
void PushDown(int o)
{
if(tree[o].lazy != -1)
{
tree[ll].lazy = tree[rr].lazy = tree[o].lazy;
tree[ll].color = tree[o].lazy;
tree[rr].color = tree[o].lazy;
tree[o].lazy = -1;
}
}
void Build(int o, int l, int r)
{
tree[o].l = l; tree[o].r = r;
tree[o].len = r-l+1;
tree[o].lazy = -1;
tree[o].color = 2;
if(l == r)
return ;
int mid = (l + r) >> 1;
Build(lson); Build(rson);
PushUp(o);
}
void update(int o, int L, int R, int v)
{
if(L <= tree[o].l && R >= tree[o].r)
{
tree[o].color = v;
tree[o].lazy = v;
return ;
}
PushDown(o);
int mid = (tree[o].l + tree[o].r) >> 1;
if(R <= mid)
update(ll, L, R, v);
else if(L > mid)
update(rr, L, R, v);
else
{
update(ll, L, mid, v);
update(rr, mid+1, R, v);
}
PushUp(o);
}
int Query(int o, int L, int R)
{
if(L <= tree[o].l && R >= tree[o].r)
return tree[o].color;
PushDown(o);
int mid = (tree[o].l + tree[o].r) >> 1;
if(R <= mid)
return Query(ll, L, R);
else if(L > mid)
return Query(rr, L, R);
else
return Query(ll, L, mid) | Query(rr, mid+1, R);
}
int main()
{
int N, Q;
while(scanf("%d%d", &N, &Q), N||Q)
{
Build(1, 1, N);
while(Q--)
{
char str[5];
Rs(str);
int x, y, z;
if(str[0] == 'P')
{
Ri(x); Ri(y); Ri(z);
update(1, x, y, 1<<(z-1));
}
else
{
Ri(x); Ri(y);
int ans = Query(1, x, y);
int use = 0;
for(int i = 0; i < 30; i++)
{
if(ans & (1<<i))
{
if(use)
printf(" ");
printf("%d", i+1);
use++;
}
}
printf("\n");
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: