您的位置:首页 > 其它

HDU-5533-Dancing Stars on Me【2015长春赛区】

2015-12-05 12:28 295 查看

HDU-5533-Dancing Stars on Me【2015长春赛区】

[code]            Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)


Problem Description

The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.

Input

The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n, denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi, describe the coordinates of n stars.

1≤T≤300

3≤n≤100

−10000≤xi,yi≤10000

All coordinates are distinct.

Output

For each test case, please output “
YES
” if the stars can form a regular polygon. Otherwise, output “
NO
” (both without quotes).

Sample Input

3

3

0 0

1 1

1 0

4

0 0

0 1

1 0

1 1

5

0 0

0 1

0 2

2 2

2 0

Sample Output

NO

YES

NO

题目链接:HDU-5533

题目大意:给出n个点,问这n个点能否组成正多边形

题目思路:比赛的时候,用凸包做感觉有bug,但是莫名其妙过了。听了题解->因为都是整数点,所以只存在正四边形这种情况。。。

以下是代码:

[code]#include <vector>
#include <map>
#include <set>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <string>
#include <cstring>
using namespace std;
int n;
struct Point{   double x, y;  }; 
Point pnt[105],res[105];
bool cmp(Point a,Point b)
{
    if (a.x != b.x) return a.x < b.x;
    else return a.y < b.y;
}
int main(){
    int t;
    cin >> t;
    while(t--)
    {
        scanf("%d",&n);         
        for (int i = 0; i < n; i++)
        {
            cin >> res[i].x >> res[i].y;
        }
        int flag = 0;
        if (n == 4)
        {
            sort(res,res + 4,cmp);
            int ok1 = (res[1].y - res[0].y) == (res[3].y - res[2].y);
            int ok2 = (res[2].x - res[0].x) == (res[3].x - res[1].x);
            if (ok1 && ok2) flag = 1;
        }
        if (flag) cout << "YES\n";
        else cout << "NO\n";
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: