您的位置:首页 > 其它

poj 3069 Saruman's Army 【贪心】【最少标记点】

2015-12-05 11:20 295 查看
Saruman's Army

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6008Accepted: 3065
Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units,
and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units
of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s
army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n =
−1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input
0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output
2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed
to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

Stanford Local 2006

思路:

先通过起点找标记点(尽可能向右找但是距离起点的距离不能大于r),然后通过标记点找下一个起点的位置,然后这个起点距标记点之间的距离大于r,然后在满足循环的前提下就将起点的位置赋值给s,继续找标记点,找起点,(记住:标记点距起点的距离小于等于r,下一个起点距标记点的距离大于r)

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int r,n;
int a[2005];
int main()
{
while(scanf("%d%d",&r,&n)&&(r!=-1||n!=-1))
{
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
sort(a,a+n);
int ans=0,i=0;
while(i<n)
{
int s=a[i];//s为最左边的没有被覆盖的点
while(i<n&&a[i]-s<=r)//寻找标记点的位置
{
i++;//标记点在距起点r的范围内,所以标记点需要减1
}
int p=a[i-1];//p是标记点的坐标
//开始从下一个点开始找下一个起点,不可能是这个标记点是下一个起点
while(i<n&&a[i]-p<=r)//寻找下一个起始点的位置
{
i++;//而下一个起点在距标记点r的范围之外,所以不用减1
}//最终i的值在大于r的范围内,也就是下一个起始点的位置
ans++;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: