您的位置:首页 > 其它

Light OJ 1078:Integer Divisibility【数学】

2015-12-05 10:59 435 查看
1078 - Integer Divisibility
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status

Description

If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3's then, the result is 6, because 333333 is divisible
by 7.

Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit(1 ≤ digit ≤ 9).

Output

For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input

3

3 1

7 3

9901 1

Sample Output

Case 1: 3
Case 2: 6
Case 3: 12
题意: 给你两个整数,n和m,问有最少有几个m组成的数能被n整除。。。。。不用同余会超时。。。。

AC-code:

#include<cstdio>
int yu(long long n,int a)
{
int i;
long long ans;
ans=a%n;
if(a%n==0)
return 1;
for(i=2;;i++)
{
ans=(ans*10+a)%n;
if(ans%n==0)
return i;
}
}
int main()
{
int T,i,m;
long long n;
scanf("%d",&T);
for(i=1;i<=T;i++)
{
scanf("%lld%d",&n,&m);
printf("Case %d: %d\n",i,yu(n,m));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: