您的位置:首页 > 其它

杭电 1003 max sum

2015-12-04 21:11 363 查看

Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 191685 Accepted Submission(s): 44647



Problem Description
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.



Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).



Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.



Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5




Sample Output
Case 1:
14 1 4

Case 2:
7 1 6




Author
Ignatius.L
/*此题妙处在于输出开始位置和结束位子*/
#include<stdio.h>
#include<string.h>
using namespace std;
int dp[1212121];
    int a[121212];
    int st[121212];//st数组是一个很巧妙的用处~
int main()
{
    int t;
    int kase=0;
    int ok=0;
    scanf("%d",&t);
    while(t--)
    {
        if(ok)printf("\n");
        ok++;
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        int n;
        scanf("%d",&n);
        int fushu=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            if(a[i]>0)fushu=1;
            st[i]=i+1;
        }
        ////////////
        if(fushu==0)
        {
            int output=-0x1f1f1f1f;
            int s;
            int e;
            for(int i=0;i<n;i++)
            {
                if(a[i]>output){output=a[i];s=i;e=i;}
            }
            printf("Case %d:\n",++kase);
            printf("%d %d %d\n",output,s+1,e+1);
            continue;
        }
        dp[0]=a[0];
        int k=0;
        int maxn=dp[0];
        int sto;
        for(int i=1;i<n;i++)
        {
            if(a[i]+dp[i-1]>=a[i]){dp[i]=dp[i-1]+a[i];st[i]=st[i-1];}
            else  dp[i]=a[i];
            if(dp[i]>maxn){maxn=dp[i];k=i;sto=st[i];}
        }
        //k+1是结尾0.0;
        printf("Case %d:\n",++kase);
        printf("%d %d %d\n",maxn,sto,k+1);
    }
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: