您的位置:首页 > Web前端

POJ 1528 Perfection

2015-12-04 19:31 267 查看
Perfection

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11999 Accepted: 5634
Description
From the article Number Theory in the 1994 Microsoft Encarta: ``If a, b, c are integers such that a = bc, a is called a multiple of b or of c, and b or c is called a divisor or factor of a. If c is not 1/-1, b is called a proper
divisor of a. Even integers, which include 0, are multiples of 2, for example, -4, 0, 2, 10; an odd integer is an integer that is not even, for example, -5, 1, 3, 9. A perfect number is a positive integer that is equal to the sum of all its positive, proper
divisors; for example, 6, which equals 1 + 2 + 3, and 28, which equals 1 + 2 + 4 + 7 + 14, are perfect numbers. A positive number that is not perfect is imperfect and is deficient or abundant according to whether the sum of its positive, proper divisors is
smaller or larger than the number itself. Thus, 9, with proper divisors 1, 3, is deficient; 12, with proper divisors 1, 2, 3, 4, 6, is abundant."

Given a number, determine if it is perfect, abundant, or deficient.

Input
A list of N positive integers (none greater than 60,000), with 1 <= N < 100. A 0 will mark the end of the list.
Output
The first line of output should read PERFECTION OUTPUT. The next N lines of output should list for each input integer whether it is perfect, deficient, or abundant, as shown in the example below. Format counts: the echoed integers
should be right justified within the first 5 spaces of the output line, followed by two blank spaces, followed by the description of the integer. The final line of output should read END OF OUTPUT.

Sample Input
15 28 6 56 60000 22 496 0

Sample Output
PERFECTION OUTPUT
15  DEFICIENT
28  PERFECT
6  PERFECT
56  ABUNDANT
60000  ABUNDANT
22  DEFICIENT
496  PERFECT
END OF OUTPUT

题意:一个数的除它本身之外的因子和,如果等于其本身,输出PERFECT,如果小于,输出DEFICIENT,如果大于,输
出ABUNDANT。。

ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<queue>
#include<iostream>
#include<algorithm>
#define MAXN 60001
#define LL long long
#define INF 0xfffffff
#define fab(x) (x)>0?(x):(-x)
#define mem(x) memset(x,0,sizeof(x))
using namespace std;
int main()
{
int n,i;
int num;
printf("PERFECTION OUTPUT\n");
while(scanf("%d",&n),n)
{
num=0;
for(i=1;i<=n/2;i++)
if(n%i==0)
num+=i;
if(num==n)
printf("%5d  PERFECT\n",n);
else if(num>n)
printf("%5d  ABUNDANT\n",n);
else
printf("%5d  DEFICIENT\n",n);
}
printf("END OF OUTPUT\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: