您的位置:首页 > 其它

1037. Magic Coupon (25)【贪心】——PAT (Advanced Level) Practise

2015-12-04 17:09 483 查看

题目信息

Magic Coupon (25)

时间限制100 ms

内存限制65536 kB

代码长度限制16000 B

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4

1 2 4 -1

4

7 6 -2 -3

Sample Output:

43

解题思路

首尾同时向中间逼近进行贪心,选择大于0 的较大值

AC代码

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
int main()
{
int n, t;
vector<int> a, b, c;
scanf("%d", &n);
while (n--){
scanf("%d", &t);
a.push_back(t);
}
scanf("%d", &n);
while (n--){
scanf("%d", &t);
b.push_back(t);
}
sort(a.begin(), a.end());
sort(b.begin(), b.end());
int ba = 0, bb = 0, ea = a.size() - 1, eb = b.size() - 1;
int s = 0;
while (ba <= ea && bb <= eb){
int f = a[ba] * b[bb];
int e = a[ea] * b[eb];
if (f >= e && f >= 0){
s += f;
++ba;
++bb;
}else if (e >= f && e >= 0){
s += e;
--ea;
--eb;
}else{
break;
}
}
printf("%d\n", s);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat 1037