您的位置:首页 > 产品设计 > UI/UE

杭电5504 GT and sequence

2015-12-04 16:58 453 查看


GT and sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2212    Accepted Submission(s): 508


Problem Description

You are given a sequence of N integers.

You should choose some numbers(at least one),and make the product of them as big as possible.

It guaranteed that **the absolute value of** any product of the numbers you choose in the initial sequence will not bigger than 263−1.

 

Input

In the first line there is a number T (test
numbers).

For each test,in the first line there is a number N,and
in the next line there are N numbers.

1≤T≤1000
1≤N≤62

You'd better print the enter in the last line when you hack others.

You'd better not print space in the last of each line when you hack others.

 

Output

For each test case,output the answer.

 

Sample Input

1
3
1 2 3

 

Sample Output

6

 

Source

BestCoder Round #60

 

Recommend

hujie   |   We have carefully selected several similar problems for you:  5589 5588 5587 5584 5583 

 
求最大积,附代码+注释:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
__int64 a[1100],ans,help,b[1100];
__int64 i,j,k,l,m,n,aans,ssum;
int cmp(__int64 a,__int64 b)
{
return a<b;
}
int main()
{
scanf("%I64d",&k);
while(k--)
{
scanf("%I64d",&n);
int num=0;
int nnum=0;
int nnnum=0;
for(i=0;i<n;i++)
{
scanf("%I64d",&help);
if(help<0)
b[nnum++]=help;//存负数
if(help>0)//存整数
a[num++]=help;
if(help==0)//记录0的个数
nnnum++;
}
sort(b,b+nnum,cmp);//把b按绝对值大小降序排序
ans=1;
aans=0;
for(i=num-1;i>=0;i--)//求出整数的积
ans*=a[i];

aans+=ans;
__int64 sum=1;
__int64 ssum=0;
if(nnum%2==0)//如果有偶数个负数
{
for(i=0;i<nnum;i++)//负数全部乘进去
sum*=b[i];
}
else
for(i=0;i<nnum-1;i++)//如果有奇数个负数
sum*=b[i];//绝对值小的不乘进去
ssum+=sum;

if(num==0&&nnum==0)//如果输入的只有0
{
printf("0\n");
continue;
}
if(num==0&&nnum==1&&nnnum==0)//如果只输入了一个负数
{
printf("%I64d\n",b[0]);
continue;
}
if(num==0&&nnum==1&&nnnum!=0)//如果输入了一个负数和若干个0
{
printf("0\n");
continue;
}
printf("%I64d\n",ssum*aans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 数学题