您的位置:首页 > 其它

杭电oj 1011

2015-12-03 22:36 351 查看
先看题目


Starship Troopers

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14960 Accepted Submission(s): 4024



Problem Description

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some
of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is
one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight
all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the
problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines
give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers,
which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

Sample Input

5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1


Sample Output

50
7


被这题搞死了,杭电各种乱报错,我也是醉了,而且还看不到错误的具体内容。看了一个晚上,原来输出的时候把endl写成了end,杭电的报错确是wa,也怪我取了一个end的变量。

废话不多说,这题是树形的背包问题,要用树形的动态规划,首先要遍历整个树,可以用DFS深度搜索整棵树。然后在遍历过程中运用动态规划。

我们先定义dp[m]
表示用n个士兵占领以m为根节点的子树所能获得的概率的最大值,f[m]
= max {f[m]
, f[m][n - k] + f[v]
},其中v是m的子节点,这样我们就完成动态规划的递推式。下面的就简单了。

下面给出我得代码

#include <iostream>
#include <cstring>
#include <vector>
using namespace std;
int N,M;
struct Room
{
int cost;
int possibility;
};
Room room[105];
int dp[105][105];
vector<int> connection[105];
void dfsTreeDp(int p,int pre)
{
int i,j,k;
for(i=room[p].cost;i<=M;i++)
dp[p][i]=room[p].possibility;
int num=connection[p].size();
for(i=0;i<num;i++)
{
int v=connection[p][i];
if(v==pre) continue;
dfsTreeDp(v,p);

for(j=M;j>=room[p].cost;j--)
for(k=1;k<=j-room[p].cost;k++)
if(dp[p][j]<dp[p][j-k]+dp[v][k])
{
dp[p][j]=dp[p][j-k]+dp[v][k];
}
}
}

int main()
{
int i,start,end;
int bug;
while((cin>>N>>M)&&(M!=-1)&&(N!=-1))
{
for(i=0;i<N;i++)
{
cin>>bug>>room[i].possibility;
room[i].cost=(bug+19)/20;
}
for(i=0;i<N;i++)
{
connection[i].clear();
}
for(i=0;i<N-1;i++)
{
cin>>start>>end;
connection[start-1].push_back(end-1);
connection[end-1].push_back(start-1);
}
if(M==0)
{
cout<<"0"<<endl;
continue;
}
memset(dp, 0, sizeof(dp));
dfsTreeDp(0,-1);
cout<<dp[0][M]<<endl;
}
}


ac了
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: