您的位置:首页 > 其它

hdoj 2795 Billboard 【单点更新】

2015-12-03 21:03 393 查看

Billboard

Time Limit: 20000/8000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 16601 Accepted Submission(s): 7020



[align=left]Problem Description[/align]
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes
in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.

[align=left]Input[/align]
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.

[align=left]Output[/align]
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't
be put on the billboard, output "-1" for this announcement.

[align=left]Sample Input[/align]

3 5 5
2
4
3
3
3


[align=left]Sample Output[/align]

1
2
1
3
-1


题意:给出一个高为h,宽为w的黑板。要贴n张海报,每张海报尽量向最左、最上贴,能贴上就输出贴在第几行,不能就输出-1。

思路:用黑板的高度作区间下标构建线段树,建树是的起始区间长度都为w,pushup更新当前区间的最大容纳宽度。每次输入宽度时,都要先查询根节点的数值是否大于输入的宽度,若小于则表示容纳不下,输出-1。

代码:

<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define M 200010
int sum[M*4];//用高度建树;
int w;
void pushup(int node)
{
sum[node]=max(sum[node*2],sum[node*2+1]);
}
void build(int l,int r,int node)
{
sum[node]=w;//初始化容纳范围为最大宽度;
if(l==r)
return ;
int mid=(l+r)/2;
build(l,mid,node*2);
build(mid+1,r,node*2+1);
}
int query(int l,int r,int a,int node)
{
if(l==r)
{
sum[node]-=a;
return l;
}
int mid=(l+r)/2;
//先将a与左子树比较,若能容纳就在左子树中查找,否则在右子树中查找;
int result=sum[node*2]>=a?query(l,mid,a,node*2):query(mid+1,r,a,node*2+1);
pushup(node);
return result;
}
int main()
{
int h,n;
int a;
while(scanf("%d%d%d",&h,&w,&n)!=EOF)
{
h=min(h,n);//张贴的高度不可能超过n行;
build(1,h,1);
for(int i=1;i<=n;i++)
{
scanf("%d",&a);
if(sum[1]<a)
printf("-1\n");
else
printf("%d\n",query(1,h,a,1));
}
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: