您的位置:首页 > 其它

POJ3186 Treats for the Cows DP

2015-12-02 20:00 253 查看

Treats for the Cows

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:

The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.

Like fine wines and delicious cheeses, the treats improve with age and command greater prices.

The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).

Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.

Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5

1

3

1

5

2

Sample Output

43

题解:

给出的一系列的数字,可以看成一个双向队列,每次只能从队首或者队尾出队,第n个出队就拿这个数乘以n,最后将和加起来,求最大和

代码

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;

int dp[2005][2005];
int a[2005];
int main()
{
int n;
while(~scanf("%d",&n)){
memset(dp,0,sizeof(dp));
for (int i = 1;i<=n;i++)
{
scanf("%d",&a[i]);
}
for (int i = 1;i<=n;i++)
dp[i][i] = a[i]*n;
int j;
for (int k = 1;k<n;k++)
{
for (int i = 1;k+i<=n;i++)
{
j = i+k;
dp[i][j] = max(dp[i+1][j]+(n-k)*a[i],dp[i][j-1]+(n-k)*a[j]);
}
}
printf("%d\n",dp[1]
);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: