您的位置:首页 > 其它

1046. Shortest Distance (20)

2015-12-02 19:59 267 查看


1046. Shortest Distance (20)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN,
where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive
integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:
3
10
7


题意:给定n个点它们围成一个圆,给定相邻两个点的距离,给出m个询问,问任意两个点之间的最短距离

模拟即可.

#include <cstdio>
#include <algorithm>
using namespace std;

int main() {
int n, m;
int sum[100010] = {0};
scanf("%d", &n);

for (int i = 1; i <= n; ++i) {
scanf("%d", sum + i);
sum[i] += sum[i - 1];
}

scanf("%d", &m);

while (m--) {
int a, b;
scanf("%d%d", &a, &b);
if (a > b) swap(a, b);
printf("%d\n", min(sum[b - 1] - sum[a - 1], sum[a - 1] + sum
- sum[b - 1]));
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: