您的位置:首页 > Web前端

HDOJ 5479 Scaena Felix (栈)

2015-12-02 19:33 471 查看

Scaena Felix

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 660    Accepted Submission(s): 275


[align=left]Problem Description[/align]
Given a parentheses sequence consist of '(' and ')', a modify can filp a parentheses, changing '(' to ')' or ')' to '('.

If we want every not empty <b>substring</b> of this parentheses sequence not to be "paren-matching", how many times at least to modify this parentheses sequence?

For example, "()","(())","()()" are "paren-matching" strings, but "((", ")(", "((()" are not.
 

[align=left]Input[/align]
The first line of the input is a integer
T,
meaning that there are T
test cases.

Every test cases contains a parentheses sequence S
only consists of '(' and ')'.

1≤|S|≤1,000.
 

[align=left]Output[/align]
For every test case output the least number of modification.
 

[align=left]Sample Input[/align]

3
()
((((
(())

 

[align=left]Sample Output[/align]

1
0
2

题意:给定一个由'('和')'组成的字符串,一次修改可以翻转字符串中的一个字符,将'('变成')'或者将')'变成
'('。如果要让这个字符串中任意一个非空子串都不是括号匹配串,至少要修改多少次?
比如"()","(())","()()" 是括号匹配串, 但"((", ")(", "((()" 不是。

思路:和括号匹配一样,存在一个括号匹配的时候,就计数cnt加一,然后最后共有多少对括号匹配,那么就要改多
少次。。

ac代码:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stack>
#include<iostream>
#include<algorithm>
#define MAXN 10001
#define LL long long
#define INF 0xfffffff
using namespace std;
char s[MAXN];
int main()
{
int t,n,m,i;
scanf("%d",&t);
while(t--)
{
stack<char>q;
//stack<char>no;
scanf("%s",s);
int len=strlen(s);
int cnt=0;
for(i=0;i<len;i++)
{
if(q.empty())
q.push(s[i]);
else
{
char ch=q.top();
if(ch=='('&&s[i]==')')
q.pop(),cnt++;
else
q.push(s[i]);
}
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: