您的位置:首页 > 运维架构

openjudge charm bracelet

2015-12-02 17:09 585 查看

7113:Charm Bracelet

查看
提交
统计
提问

总时间限制: 1000ms 内存限制: 65536kB
描述

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1
≤ Wi≤ 400), a 'desirability' factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

输入Line 1: Two space-separated integers: N and M

Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di
输出Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints
样例输入
4 6
1 4
2 6
3 12
2 7


样例输出
23


#include<iostream>

#include<cstdio>

#include<cstring>

using namespace std;

int n,m,i,j;

int f[12888],w[3420],v[3420];

int main()

{
scanf("%d%d",&n,&m);
for (i=1;i<=n;i++)
 scanf("%d%d",&w[i],&v[i]);
memset(f,0,sizeof(f));

    for (i=1;i<=n;i++)
 for (j=m;j>=w[i];j--)
   f[j]=max(f[j],f[j-w[i]]+v[i]);

    cout<<f[m];
return 0; 

}

//此题为标准的01背包
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: