您的位置:首页 > 其它

1043. Is It a Binary Search Tree (25)

2015-12-02 16:57 375 查看


1043. Is It a Binary Search Tree (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.

The right subtree of a node contains only nodes with keys greater than or equal to the node's key.

Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All
the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
Sample Input 1:
7
8 6 5 7 10 8 11

Sample Output 1:
YES
5 7 6 8 11 10 8

Sample Input 2:
7
8 10 11 8 6 7 5

Sample Output 2:
YES
11 8 10 7 5 6 8

Sample Input 3:
7
8 6 8 5 10 9 11

Sample Output 3:
NO

题意: 给定一棵树的先序遍历, 闻其是否是一棵二叉搜索树或者是一棵二叉搜索树的镜像, 如果是,给出这棵树的后序遍历
题解:如果是一棵二叉搜索树的话,按照它的先序遍历的顺序重新构建一棵二叉搜索树,会得到和原来的树一样的二叉搜索树,
         如果是一棵二叉搜索树的镜像,那么按照他的先序遍历顺序重新构建的二叉搜索树,他的后序遍历翻转过来会和原来的先序遍历是一样的~~仔细想一下就会明白.

#include <cstdio>
#include <cstdlib>
#include <vector>
#include <algorithm>

using namespace std;

typedef struct node{
int data;
struct node* left;
struct node* right;
}Node, *pNode;

pNode new_node() {
pNode root = (pNode)malloc(sizeof(Node));
root->left = root->right = NULL;
return root;
}

void insert(pNode& root, int data) {
if (root == NULL) {
root = new_node();
root->data = data;
}
else {
if (data < root->data) insert(root->left, data);
else insert(root->right, data);
}
}

void pre_order(const pNode& root, vector<int>& v) {
if (root == NULL) return ;
v.push_back(root->data);
pre_order(root->left, v);
pre_order(root->right, v);
}

void post_order(const pNode& root, vector<int>& v) {
if (root == NULL) return ;
post_order(root->left, v);
post_order(root->right, v);
v.push_back(root->data);
}

int main() {
int n;
scanf("%d", &n);
vector<int> ary(n), pre_order_ary, post_order_ary;
pNode root = NULL;

for (int i = 0; i < n; ++i) {
scanf("%d", &ary[i]);
insert(root, ary[i]);
}

pre_order(root, pre_order_ary);
post_order(root, post_order_ary);

reverse(post_order_ary.begin(), post_order_ary.end());
if (ary == pre_order_ary) {
puts("YES");
reverse(post_order_ary.begin(), post_order_ary.end());
for (int i = 0; i < post_order_ary.size(); ++i)
printf("%d%c", post_order_ary[i], i == post_order_ary.size() - 1 ? '\n' : ' ');
}
else if (ary == post_order_ary) {
puts("YES");
reverse(pre_order_ary.begin(), pre_order_ary.end());
for (int i = 0; i < pre_order_ary.size(); ++i)
printf("%d%c", pre_order_ary[i], i == pre_order_ary.size() - 1 ? '\n' : ' ');
}
else {
puts("NO");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: