您的位置:首页 > 其它

ZZULIOJ 1724 candy

2015-12-02 13:26 381 查看

Description

Kimi has a lot of candies, and divides them into piles, where the
ith pile contains Ai candies. Each time Kimi will choose an interval [l,r], and calculate the total amount of
Al,Al+1,…,Ar. It's a hard task, and you're required to solve it.

Input

An integer T(T≤10) will exist in the first line of input, indicating the number of test cases. Each test case begins with the number of piles
N(1≤N≤105). The second line contains N integers
Ai(1≤Ai≤100), where Ai stands for the number of candies in the
ith pile. The next line is the number of queries M(1≤M≤105). The next
M lines, each with two integers l,r(1≤l≤r≤N), describe the queried intervals.

Output

For each test case, output the total amount of candies in the queried interval.

Sample Input

151 2 4 5 931 22 44 5


Sample Output

31114


看懂题,然后注意不超时就好了。

看懂题是关键_(:з」∠)_

#include<stdio.h>
int a[110000];
int b[110000]={0};
int main()
{
int t,n,m;
int i,l,r;
while(~scanf("%d",&t))
{
while(t--)
{

scanf("%d",&n);
for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
b[i]=b[i-1]+a[i];
}
scanf("%d",&m);
while(m--)
{
int sum=0;
scanf("%d%d",&l,&r);
sum=b[r]-b[l-1];
printf("%d\n",sum);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: