您的位置:首页 > 其它

hdu1115 Lifting the Stone (求多边形重心)

2015-12-02 12:01 447 查看


Lifting the Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6716    Accepted Submission(s): 2794

Problem Description

There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly
and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly
to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon. 

 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed
by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the
neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line. 

 

Output

Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal
point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway. 

 

Sample Input

2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11

 

Sample Output

0.00 0.00
6.00 6.00

 

Source

Central Europe 1999

 

Recommend

Eddy   |   We have carefully selected several similar problems for you:  1392 2108 2150 1348 1147 

 

解析:http://www.cnblogs.com/jbelial/archive/2011/08/08/2131165.html
代码:
#include<cstdio>
#include<cmath>
using namespace std;

struct tnode{
double x,y;
}p[3];

double get_s()
{
double a,b;
a=(p[1].x-p[0].x)*(p[2].y-p[0].y);
b=(p[2].x-p[0].x)*(p[1].y-p[0].y);
return (a-b)/2;//²»ÄÜдabs(a-b)/2
}
int main()
{
freopen("1.in","r",stdin);

int t,n;
double sx,sy,s,ss;
scanf("%d",&t);
while(t--)
{
sx=sy=s=0;
scanf("%d",&n);
scanf("%lf%lf",&p[0].x,&p[0].y);
scanf("%lf%lf",&p[1].x,&p[1].y);
for(n-=2;n;n--)
{
scanf("%lf%lf",&p[2].x,&p[2].y);
s+=(ss=get_s());
sx+=(p[0].x+p[1].x+p[2].x)*ss;
sy+=(p[0].y+p[1].y+p[2].y)*ss;
p[1]=p[2];
}
printf("%.2lf %.2lf\n",sx/s/3,sy/s/3);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: