您的位置:首页 > 其它

POJ1703Find them, Catch them

2015-12-01 17:34 190 查看
Find them, Catch them

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 37722Accepted: 11632
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] [b]
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.
Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.
Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."
Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

又把种类并查集复习了一遍发现以前写的好乱。
做这种题就是要设一种关系用来表示它与父节点的关系,用a[x]来表示x与x父节点的关系,a[x] == 0表示x与父节点同类,否则异类
那么x的父节点与x的关系是跟x与他父节点的关系是一样的,这点比食物链那题简单
而求子节点与爷爷节点关系公式 (a[father[x] + a[x] ) % 2;通过枚举可以得到。因此在find_fahter更改关系时提供了凭据


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int MAX = 100000+10;
struct person
{
int num;
int bang;
int father;
};
person per[MAX];
int find_father(person &node)
{
if(node.father == node.num)
return node.father;
int temp = node.father;   //这个很重要,因为是通过当前数与父节点关系,父节点与总父节点的关系来判断当前数与总父节点的关系,
node.father = find_father(per[temp]);
node.bang = (node.bang + per[temp) % 2; //本来这里写的是(node.bang + per[node.father))%2; 因为经过上一步递归更新父节点,此时的node.father已经是总父节点了,so...
return node.father;
}
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
int n,m,a,b,fa,fb;
char c;
scanf("%d%d", &n,&m);
getchar();
for(int i = 0; i <= n; i++)
{
per[i].num = i;
per[i].father = i;
per[i].bang = 0;
}
while(m--)
{
scanf("%c%d%d", &c,&a,&b);
getchar();

if(c == 'D')
{
fa = find_father(per[a]);
fb = find_father(per[b]);
if(fa != fb) {
per[fb].father = fa;
if(per[a].bang== 0)    //这里要举例找规律
per[fb].bang = 1 - per[b].bang;
else
per[fb].bang = per[b].bang;
}
}
else if(c == 'A')
{
fa = find_father(per[a]);
fb = find_father(per[b]);
if(fa != fb)
printf("Not sure yet.\n");
else
{
if(per[a].bang == per[b].bang)
printf("In the same gang.\n");
else
printf("In different gangs.\n");
}
}

}
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: