您的位置:首页 > 其它

1052. Linked List Sorting (25)

2015-12-01 16:39 246 查看
A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures
according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive
integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no
cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.
Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345

Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

---------------华丽的分割线----------------
分析:先把输入存下来,然后遍历,把符合条件的收到另一个数组里,最后输出。
代码:
#include<cstdio>
#include<cstdlib>

#define Maxn 100001

typedef struct
{
int address;
int key;
int next;
}Node;

Node input[Maxn];
Node result[Maxn];

int cmp(const void *a,const void *b);

int main(void)
{
int N,header;
scanf("%d %5d",&N,&header);
int i;
int inaddr,inkey,innext;
for(i=0;i<N;++i)
{
scanf("%5d %d %d",&inaddr,&inkey,&innext);
input[inaddr].address = inaddr;
input[inaddr].key = inkey;
input[inaddr].next = innext;
}
int thisnode = header;
int realnode = 0;
while(thisnode != -1)
{
result[realnode] = input[thisnode];
thisnode = input[thisnode].next;
++realnode;
}

if(realnode == 0)
{
printf("0 -1\n");
return 0;
}

qsort(result,realnode,sizeof(result[0]),cmp);

header = result[0].address;

bool firstnode = true;

printf("%d %05d\n",realnode,header);

for(i=0;i<realnode;++i)
{
if(firstnode)
{
printf("%05d %d ",result[i].address,result[i].key);
firstnode = false;
}
else
{
printf("%05d\n",result[i].address);
printf("%05d %d ",result[i].address,result[i].key);
}

if(i == realnode - 1)
{
printf("-1\n");
}
}

system("pause");
return 0;
}

int cmp(const void *a,const void *b)
{
Node tempa = *(Node *)a;
Node tempb = *(Node *)b;

return tempa.key - tempb.key;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: