您的位置:首页 > 其它

1037. Magic Coupon (25)贪心

2015-12-01 15:54 330 查看


1037. Magic Coupon (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product
for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon
2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC,
NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3

Sample Output:
43


题解:这题采取贪心策略,首先,把两个数组按从小到大的顺序排序,然后从两个数组中各选取一个数,使他们的乘积最大,知道没法选为止,最后的和即为答案.

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
typedef long long LL;
const int N = 100010;

int main() {
LL c
, p
;
int nc, np;
scanf("%d", &nc);
for (int i = 0; i < nc; ++i) scanf("%lld", c + i);
scanf("%d", &np);
for (int i = 0; i < np; ++i) scanf("%lld", p + i);

sort(c, c + nc);
sort(p, p + np);
int pc1 = 0, pc2 = nc - 1;
int pp1 = 0, pp2 = np - 1;
LL ans = 0;
while (pc1 <= pc2 && pp1 <= pp2) {
if (c[pc1] * p[pp1] > c[pc2] * p[pp2]) {
if (c[pc1] * p[pp1] > 0) ans += c[pc1] * p[pp1];
else break;
++pc1,++pp1;
}
else {
if (c[pc2] * p[pp2] > 0) ans += c[pc2] * p[pp2];
else break;
--pc2, --pp2;
}
}

printf("%lld\n", ans);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: