您的位置:首页 > 其它

POJ 3349 哈希

2015-11-30 22:56 405 查看
Snowflake Snow Snowflakes

Time Limit: 4000MS Memory Limit: 65536K

Total Submissions: 35803 Accepted: 9441

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:

No two snowflakes are alike.

If there is a pair of possibly identical snow akes, your program should print the message:

Twin snowflakes found.

Sample Input

2

1 2 3 4 5 6

4 3 2 1 6 5

Sample Output

Twin snowflakes found.

题意:

给出多个雪花,问有没有两片完全一样的雪花。不论正时针转还是逆时针转,对上号就行。

题解:

做一个哈希表,然后查询,本题用的键值k = (a[0]%M+a[1]%M+a[2]%M+a[3]%M+a[4]%M+a[5]%M)%M

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#define M 999983

using namespace std;

struct Po{
int v[6];
Po* next;
};

Po* Hash[M+5] = {NULL};
int mo[] = {0,1,2,3,4,5};
int mo1[] = {5,4,3,2,1,0};

bool IsTrue(Po* tem,Po* p){
int i,j;
int OK = 0;
for(i = 0;i<6;i++){
int ok = 1;
for(j = 0;j<6;j++){
if(tem->v[j]!=p->v[(mo[j]+i)%6]){
ok = 0;
break;
}
}
if(ok){
OK = 1;
break;
}
}
for(i = 0;i<6;i++){
int ok = 1;
for(j = 0;j<6;j++){
if(tem->v[j]!=p->v[(mo1[j]+i)%6]){
ok = 0;
break;
}
}
if(ok){
OK = 1;
break;
}
}
if(OK) return true;
else return false;
}

int main()
{
//    freopen("data.in","r",stdin);
int N;
int a[6];
scanf("%d",&N);
int ok = 0;
while(N--){
int k = 0;
int i,j;
Po* tem;
tem = (Po*)malloc(sizeof(Po));
tem->next = NULL;
for(i = 0;i<6;i++){
scanf("%d",&a[i]);
tem->v[i] = a[i];
k+=a[i]%M;
}
if(ok){
free(tem);
continue;
}
k%=M;
if(Hash[k]==NULL){
Hash[k] = tem;
}else{
Po* p = Hash[k];
while(p!=NULL){
if(IsTrue(tem,p)){
ok = 1;
break;
}
p = p->next;
}
if(ok == 0){
tem->next = Hash[k];
Hash[k] = tem;
}
}
}
if(ok) printf("Twin snowflakes found.\n");
else printf("No two snowflakes are alike.\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj