您的位置:首页 > 其它

hdoj To The Max 1081 (二维DP)

2015-11-30 21:34 253 查看

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10290    Accepted Submission(s): 4950


[align=left]Problem Description[/align]
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle.
In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

 

[align=left]Input[/align]
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace
(spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will
be in the range [-127,127].

 

[align=left]Output[/align]
Output the sum of the maximal sub-rectangle.

 

[align=left]Sample Input[/align]

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

 

[align=left]Sample Output[/align]

15 
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int map[200][200];
int n,m,mm;
void find(int x)
{
int t=0;
int i,j;
for(i=0;i<n;i++)
{
if(t>0)
t+=map[x][i];
else
t=map[x][i];
mm=max(mm,t);
}
}
int main()
{
int i,j,k;
while(scanf("%d",&n)!=EOF)
{
memset(map,0,sizeof(map));
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%d",&map[i][j]);
mm=map[0][0];
for(i=0;i<n;i++)
{
find(i);
for(j=i+1;j<n;j++)
{
for(k=0;k<n;k++)
{
map[i][k]+=map[j][k];
}
find(i);
}
}
printf("%d\n",mm);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: