您的位置:首页 > 大数据 > 人工智能

Uva514-Rails(基本栈)

2015-11-30 19:55 591 查看
There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out
that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.



The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has


coaches numbered in increasing order


. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in
the direction B so that their order will be

. Help him and write a program that decides whether
it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose
that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the
station.

Input

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer
N described above. In each of the next lines of the block there is a permutation of


The last line of the block contains just 0.
The last block consists of just one line containing 0.

Output

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains
Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains
No. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0


Sample Output

Yes
No

Yes

利用车站C作为中转站,车只能A→C或者C→B,开进C的车不能回到A。很明显,C是一个栈。
所以模拟这个过程,用一个变量a表示正常次序的车辆变好,将目标顺序放进一个数组t[maxn]里面,然后依次遍历,有两种情况存在,一个是a正好等于t[i],这种情况就是不用在C停留,直接从A→B,另外一种就是a不等于t[i],若此时栈中有车辆,并且栈顶元素等于t[i],则出栈,于是i++

代码如下:

#include <iostream>
#include <stack>
#include <cstdio>
using namespace std;
const int maxn = 1010;
int n,t[maxn];
/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char** argv)
{
while(scanf("%d",&n)!=-1&&n)
{

while(scanf("%d",&t[1])!=-1&&t[1])
{
for(int i=2;i<=n;i++)
scanf("%d",&t[i]);
bool flag=true;
int a=1,b=1;
stack<int> s;
while(b<=n)
{
if(a==t[b])
{
a++;b++;
}
else if(!s.empty()&&s.top()==t[b])
{
s.pop();b++;
}
else if(a<=n)
{
s.push(a++);
}
else
{
flag=false;break;
}
}
printf("%s\n",flag?"Yes":"No");
}
cout<<endl;

}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: