您的位置:首页 > 其它

1031. Hello World for U (20)

2015-11-30 17:26 465 查看


1031. Hello World for U (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, "helloworld" can be printed as:
h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and
finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n1 = n3 =
max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.
Sample Input:
helloworld!

Sample Output:
h   !
e   d
l   l
lowor

题意: 给定一个字符串,问能否打印出一个U字的形状来
模拟即可.

#include <cstdio>
#include <cstring>

int main() {
char str[100];
scanf("%s", str);

int len = strlen(str);
int n = (len + 2) / 3;

for (int i = 0; i < n - 1; ++i) {
putchar(str[i]);
for (int j = 0; j < len - n * 2; ++j) putchar(' ');
putchar(str[len - i - 1]);
puts("");
}

for (int i = n - 1; i <= len - n ; ++i)
putchar(str[i]);
puts("");

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: