您的位置:首页 > 其它

1028. List Sorting (25)

2015-11-29 21:32 399 查看


1028. List Sorting (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record
of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records
must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.
Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90


题解: 结构体排序就好了.

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int C;
struct node{
int id, score;
char str[20];
}stu[100010];

bool cmp(const node & a, const node & b) {
if (C == 1)
return a.id < b.id;
else if (C == 2) {
if (strcmp(a.str, b.str) == 0) return a.id < b.id;
return strcmp(a.str, b.str) < 0;
}
else {
if (a.score == b.score) return a.id < b.id;
return a.score < b.score;
}
}

int main() {
int n;
scanf("%d%d", &n, &C);

for (int i = 0; i < n; ++i)
scanf("%d%s%d", &stu[i].id, stu[i].str, &stu[i].score);

sort(stu, stu + n, cmp);
for (int i = 0; i < n; ++i)
printf("%06d %s %d\n", stu[i].id, stu[i].str, stu[i].score);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: