您的位置:首页 > 大数据 > 人工智能

1079. Total Sales of Supply Chain (25)

2015-11-29 21:16 399 查看
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain
has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the
root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being
0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.
Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:
42.4

------------------------华丽的分割线--------------------------
分析:用并查集存下输入节点信息,然后计算输出。
代码:
#include <cstdio>
#include <cstdlib>
#include <cmath>

#define Maxn 100001

int input[Maxn];		//input[i]是i的父节点
int level[Maxn];			//level[i]表示i在第几层,根节点为1
int isretailor[Maxn];  //0表示不是retailor,isretailor[i] > 0表示i有多少货。

int N;
double P,r;

int countlevel(int node);

int main(void)
{
scanf("%d %lf %lf\n",&N,&P,&r);
int i,j,k;
int value;

for(i=0;i<N;++i)
{
scanf("%d",&k);
if(k==0)
{
scanf("%d",&value);
isretailor[i]=value;
}
else
{
for(j=0;j<k;++j)
{
scanf("%d",&value);
input[value] = i;
}
}
}

level[0] = 1;
for(i=1;i<N;++i)
{
level[i] = countlevel(i);
}
double sum = 0;
for(i=0;i<N;++i)
{
if(isretailor[i])
{
sum += P*pow((1+r/100),level[i] - 1)*isretailor[i];
}
}
printf("%.1f",sum);
system("pause");
return 0;
}

int countlevel(int node)
{
if(level[node] != 0)
return level[node];
else
{
return level[node] = countlevel(input[node])+1;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: