您的位置:首页 > 其它

HDU ACM 2138 How many prime numbers

2015-11-29 01:06 274 查看

原题描述

Problem Description

Give you a lot of positive integers, just to find out how many prime numbers there are.

Input

There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.

Output

For each case, print the number of prime numbers you have found out.

Sample Input

3

2 3 4

Sample Output

2

解题思路

本题求一组数中素数的个数。

求一个数是否是素数,把这个数一次除以2到他的平方根的整数,如果某个结果能整除,则不是素数。

参考代码

#include <iostream>
#include <cmath>
using namespace std;
bool isPrime(int x)                         // 调用函数比直接在main中判断更快
{
if (x == 1)return false;
for (int i = 2; i < sqrt(x); i++)       // 只要到sqrt(x)即可
if (x%i == 0)
return 0;
return 1;
}
int main()
{
int n, c, s;
while (~scanf("%d",&n))
{
s = 0;
for (int i = 0; i < n;i++)
{
scanf("%d", &c);
if (isPrime(c))
s++;
}
printf("%d\n", s);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: