您的位置:首页 > 其它

HDOJ 5585 Numbers

2015-11-28 22:09 423 查看


Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 20    Accepted Submission(s): 15


[align=left]Problem Description[/align]
There is a number N.You should output "YES" if N is a multiple of 2, 3 or 5,otherwise output "NO".
 

[align=left]Input[/align]
There are multiple test cases, no more than 1000 cases.

For each case,the line contains a integer N.(0<N<1030)
 

[align=left]Output[/align]
For each test case,output the answer in a line.
 

[align=left]Sample Input[/align]

2
3
5
7

 

[align=left]Sample Output[/align]

YES
YES
YES
NO

 

水,脑残,str[i]=='0'写成了str[i]==0,WA好几次

代码如下:

#include<cstdio>
#include<cstring>
char str[100];
int main()
{
int i,n;
while(scanf("%s",&str)!=EOF)
{
int len=strlen(str);
int sum=0;
for(i=0;i<len;++i)
sum+=str[i]-'0';
if((str[len-1]-'0')%2==0)//判断是否是2的倍数
printf("YES\n");
else if(str[len-1]=='0'||str[len-1]=='5')//判断是否是5的倍数
printf("YES\n");
else if(sum%3==0)//判断是否是3的倍数
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: