您的位置:首页 > 其它

Rightmost Digit

2015-11-28 21:55 441 查看
[align=left]Problem Description[/align]
Given a positive integer N, you should output the most right digit of N^N.

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

[align=left]Output[/align]
For each test case, you should output the rightmost digit of N^N.

[align=left]Sample Input[/align]

2
3
4


[align=left]Sample Output[/align]

7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.


求结果的最后一位,快速幂加同余定理(%10),以前做过类似的题。。。

#include<stdio.h>
int f(int a,int b)
{
int ans=1;
a=a%10;
while(b>0)
{
if(b&1)
ans=(ans*a)%10;
b= b>>1;
a=(a*a)%10;
}

return ans;
}
int main()
{
int n,t;
int result;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
result=f(n,n);
printf("%d\n",result);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: