您的位置:首页 > 产品设计 > UI/UE

hdoj 5567 sequence1 【水题】

2015-11-28 11:44 387 查看


sequence1

                                                                         Time Limit: 2000/1000 MS (Java/Others)    Memory Limit:
65536/65536 K (Java/Others)

                                                                                                      Total Submission(s): 18    Accepted Submission(s): 17


Problem Description

Given an array a with
length n,
could you tell me how many pairs (i,j) (
i < j ) for abs(ai−aj) mod b=c.

 

Input

Several test cases(about 5)

For each cases, first come 3 integers, n,b,c(1≤n≤100,0≤c<b≤109)

Then follows n integers ai(0≤ai≤109)

 

Output

For each cases, please output an integer in a line as the answer.

 

Sample Input

3 3 2
1 2 3
3 3 1
1 2 3

 

Sample Output

1
2

 

很水的题目,签到吧。

AC代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define INF 0x3f3f3f3f
#define MAXN 100
#define MAXM 1010
#define eps 1e-8
#define LL long long
using namespace std;
LL b, c;
LL a[110];
bool judge(LL x, LL y){
return abs(x - y) % b == c;
}
int main()
{
int n;
while(scanf("%d%lld%lld", &n, &b, &c) != EOF)
{
int ans = 0;
for(int i = 0; i < n; i++)
scanf("%lld", &a[i]);
for(int i = 0; i < n; i++)
for(int j = i+1; j < n; j++)
if(judge(a[i], a[j]))
ans++;
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: