您的位置:首页 > 其它

HDU 2955 Robberies

2015-11-28 01:01 295 查看

Robberies

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 17647 Accepted Submission(s): 6516


[align=left]Problem Description[/align]
The aspiring(有抱负的) Roy the Robber has seen a lot of American movies, and knows that the bad
guys(球员) usually gets caught in the end, often because they become too greedy. He has decided to work in the
lucrative(有利可图的) business of bank robbery only for a short while, before retiring to a comfortable job at a university.



For a few months now, Roy has been assessing(评定) the security of various banks and the
amount(数量) of cash they hold. He wants to make a
calculated(计算出的)
risk(风险), and grab as much money as possible.

His mother, Ola, has decided upon a tolerable(可以的)
probability(可能性) of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

[align=left]Input[/align]
The first line of
input(投入) gives T, the number of cases. For each
scenario(方案), the first line of input gives a floating point number P, the
probability(可能性) Roy needs to be below, and an
integer(整数) N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

[align=left]Output[/align]
For each test case,
output(输出) a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt(破产者) if it is robbed, and you may
assume(承担) that all probabilities are independent as the police have very low funds.

[align=left]Sample Input[/align]

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05


[align=left]Sample Output[/align]

2
4
6


题目意思是给定给定一个概率,是被抓的概率,给定几个银行,每个银行对应一个钱数和被抓的概率,如何在有效的被抓概率内偷更多的钱?

显然是个0-1背包的问题,一开始把这个当成了一个概率简单相加的问题,看了讨论区发现傻了。。其实概率应该是相乘的。设个一维DP,代表对应money被抓的概率,最后反向寻找第一个概率大于1 - 被抓的概率的就好。

代码如下:

/*************************************************************************
> File Name: 0-1_bags.cpp
> Author: Zhanghaoran
> Mail: chilumanxi@xiyoulinux.org
> Created Time: Fri 27 Nov 2015 11:21:43 PM CST
************************************************************************/

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>

using namespace std;
float dp[10010];
int main(void){
int T, n;
float p;
int mon[10010];
float pro[10010];
int all = 0;
cin >> T;
while(T --){
all = 0;
scanf("%f%d",&p,&n);
memset(dp, 0, sizeof(dp));
for(int i = 1; i <= n; i ++){
scanf("%d%f",&mon[i],&pro[i]);
all += mon[i];
}

dp[0] = 1;
for(int i = 1; i <= n; i ++){
for(int j = all; j >= mon[i]; j --){
dp[j] = max(dp[j], dp[j - mon[i]] * (1 - pro[i]));
}
}

for(int i = all; i >= 0; i --){
if(dp[i] >= (1 - p)){
printf("%d\n", i);
break;
}
}

}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: