您的位置:首页 > 其它

virtual judge(专题一 简单搜索 E)

2015-11-27 23:48 232 查看
Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0


Sample Output

10
100100100100100100
111111111111111111


#include"cstdio"
using namespace std;
int n;
unsigned long long ans;
bool flag;
void dfs(unsigned long long i,int k)
{
if(flag)    return;    //找结果之后就直接返回
if(i%n==0)
{
flag=true;
ans=i;
return;
}
if(k==19)    return; //答案在19为之内,无符号long long 可以保存结果
dfs(i*10+0,k+1);
dfs(i*10+1,k+1);
}
int main()
{
while(scanf("%d",&n)!=EOF&&n!=0)
{
flag=false;
dfs(1,0);
printf("%llu\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: