您的位置:首页 > 其它

hdu 3466 Proud Merchants

2015-11-27 21:01 344 查看

Proud Merchants

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 3918    Accepted Submission(s): 1639

[align=left]Problem Description[/align]
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any
more.

The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.

If he had M units of money, what’s the maximum value iSea could get?

 

[align=left]Input[/align]
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.

Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

[align=left]Output[/align]
For each test case, output one integer, indicating maximum value iSea could get.

 

[align=left]Sample Input[/align]

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3

 

[align=left]Sample Output[/align]

5
11贪心过程:假设A,B两个物品,要使得先后顺序让所需空间最小,才能让后面的价值可能越大
假如A先放,则需要空间 q1+p2;
B先放,则所需空间为   q2+p1;
假如要让A排在前面,则排序方式为 q1+p2<q2+p1#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct Node
{
int p,q,v;
}node[510];
int cmp(Node a,Node b)
{
return a.q-a.p<b.q-b.p;
}
int main()
{
int m,n;
while(scanf("%d%d",&n,&m)!=EOF)
{
int i,j;
for(i=0;i<n;i++)
{
int p,q,v;
scanf("%d%d%d",&p,&q,&v);
Node N={p,q,v};
node[i]=N;
}
sort(node,node+n,cmp);
int dp[5010];
memset(dp,0,sizeof(dp));
for(i=0;i<n;i++)
for(j=m;j>=node[i].q;j--)
dp[j]=max(dp[j],dp[j-node[i].p]+node[i].v);
printf("%d\n",dp[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: