您的位置:首页 > 其它

hdu 2602 Bone Collector

2015-11-27 19:59 288 查看

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 42169    Accepted Submission(s): 17538

[align=left]Problem Description[/align]
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



 

[align=left]Input[/align]
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 

[align=left]Output[/align]
One integer per line representing the maximum of the total value (this number will be less than 231).
 

[align=left]Sample Input[/align]

1
5 10
1 2 3 4 5
5 4 3 2 1

 

[align=left]Sample Output[/align]

14
#include<stdio.h>
#include<string.h>
#define max(a,b) (a)>(b)?(a):(b)
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int i,j,n,volume;
int v[1010],w[1010],dp[1010];
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&volume);
for(i=0;i<n;i++)
scanf("%d",&v[i]);
for(i=0;i<n;i++)
scanf("%d",&w[i]);
for(i=0;i<n;i++)
for(j=volume;j>=w[i];j--)
dp[j]=max(dp[j-w[i]]+v[i],dp[j]);
printf("%d\n",dp[volume]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: