您的位置:首页 > 编程语言 > Java开发

java hdu2088

2015-11-27 19:26 555 查看


[align=left]Problem Description[/align]
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I've built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height.
Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with
the minimum number of bricks moved. Can you help?



[align=left]Input[/align]
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.

[align=left]Output[/align]
For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.

Output a blank line between each set.

[align=left]Sample Input[/align]

6
5 2 4 1 7 5
0


[align=left]Sample Output[/align]

5


import java.util.Scanner;

class P2088 {

//class Main{

public static void main(String[] args) {

Scanner sc=new Scanner(System.in);

int boo=0;//注意设置标志以及他的作用域

while(sc.hasNext()){

int n=sc.nextInt();

if(n==0){

break;

}

int sum=0,avg,count=0;

int a[]=new int
;

for(int i=0;i<n;i++){

a[i]=sc.nextInt();

sum+=a[i];

}

avg=sum/n;

for(int i=0;i<n;i++){

if(a[i]>avg){

count+=a[i]-avg;

}

}

if(boo!=0){

System.out.println();

}

boo++;

System.out.println(count);

}

}

}

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: